<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424,115551496","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":0,"applicationTime":341,"agent":""}</script>
<script>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</script>
<!-- GUCE -->
<meta content='false' name='oath:guce:product-eu'>
<meta content='guce.rivals.com' name='oath:guce:consent-host'>
<script src="https://s.yimg.com/oa/guce.js" async="async"></script>
<script>
  var googleAnalyticsId = "UA-83297409-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>CavsCorner.com  -  Weekend Wrap: Loss to NCSU an accurate frame for where UVa is</title>
<meta content='CavsCorner.com  -  Weekend Wrap: Loss to NCSU an accurate frame for where UVa is' property='og:title'>

<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-f4be6c0dd7800bdff795261ecf3453dc015b50d92d44c6c8247d648d6b32a0b3.css" />


<script src="https://cdn.rivals.com/production/assets/lib-885a9c7419ce2642514a0b75edce6953724e319a1617ef3c42ae722c0fc80ef2.js"></script>
<script src="https://cdn.rivals.com/production/assets/application-d35545c062e3b2a0b0c54b5e3191a9861d4fe280d6e6d517a18cced070e3c808.js"></script>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="jRUgB6p4jjKr8Thvf2Qp0Zmh8DOyLzpzOg6u1GA2/fJNlT4eCfDgDQpCc/rJJYiLyEzVbvO8QlsKPjQFMWTZxQ==" />
<script>
  (function () {
    'use strict';
  
    angular.module('rivals').factory('userPaths', function () {
      var basePath = "rivals.com";
  
      var siteUrl = function(subdomain) {
        if(subdomain === 'rivals') {
          return window.location.protocol + '//' + basePath;
        } else {
          return window.location.protocol + '//' + subdomain + '.' + basePath;
        }
      };
  
      var trendingThreads = function(baseUrl, forum) {
        return baseUrl + 'api/threads/' + forum + '/trending';
      };
  
      var publishingDashboardUrl = function(subdomain) {
        return siteUrl(subdomain) + '/publishing/contents';
      };
  
      var commitmentsRelativePath = function (page, year) {
        var url;
        if (!page || (page != 'rivals150' && page != 'basketball')) {
          url = "/commitments/football"
        } else {
          url = "/commitments/basketball"
        }
  
        return url + (year ? '/' + year : '');
      };
  
      var commitmentsPath = function (page, year) {
        return basePath + commitmentsRelativePath(page, year);
      };
  
  
      var apiV1RanksProspectsPath = function (rank_id) {
        return "/api/v1/ranks/:rank_id/prospects".replace(/\:rank_id/i, rank_id);
      };
  
      var editContentsPath = function (content_id) {
        return "/publishing/contents/:content_id/edit".replace(/\:content_id/i, content_id);
      };
  
      var apiV1RankPeoplePath = function (rank_id) {
        return "/api/v1/people/rank/:rank_id".replace(/\:rank_id/i, rank_id);
      };
  
      var apiV1ForecastGraphPath = function (prospect_id) {
        return "/api/v1/content/forecast_graph/:prospect_id".replace(/\:prospect_id/i, prospect_id);
      };
  
      var apiV1ForecastTablePath = function (prospect_id) {
        return "/api/v1/content/forecast_table/:prospect_id".replace(/\:prospect_id/i, prospect_id);
      };
  
      var forecasterPagePath = function (user_id) {
        return basePath + "/content/forecaster_profiles/:user_id".replace(/\:user_id/i, user_id)
      };
  
      return {
        adminHomePath: "/admin/home",
        highschoolApiPath: "/api/v1/content/highschools",
        apiV1BreakingNewsPath: "/api/v1/breaking_news",
        apiV1ContentCollegesPath: "/api/v1/content/colleges",
        apiV1ContentContentsPath: "/api/v1/content/contents",
        apiV1ContentHighschoolsPath: "/api/v1/content/highschools",
        apiV1CustomModules: "/api/v1/custom_modules",
        apiV1CustomModulesPath: "/api/v1/custom_modules/id",
        apiV1EventsPath: "/api/v1/events",
        apiV1FavoriteBlocksPath: "/api/v1/publishing/favorite_blocks",
        apiV1FlipperShowPath: "/api/v1/flipper",
        apiV1ForecastGraphPath: apiV1ForecastGraphPath,
        apiV1ForecastTablePath: apiV1ForecastTablePath,
        apiV1ContentForecastsPath: "/api/v1/content/forecasts",
        apiV1ContentTopForecastsPath: "/api/v1/content/forecasts/top_forecasts",
        apiV1GalleriesPath: "/api/v1/galleries",
        apiV1HpCustomModules: "/api/v1/hp_custom_modules",
        apiV1HpEnrichments: "/api/v1/hp_enrichments",
        apiV1ImagesPath: "/api/v1/images",
        apiV1ProspectRankingsPath: "/api/v1/prospect_rankings",
        apiV1RankPeoplePath: apiV1RankPeoplePath,
        apiV1RanksProspectsPath: apiV1RanksProspectsPath,
        apiV1TrendingContentsPath: "/api/v1/trending_contents",
        apiV1UsersPath: "/api/v1/users",
        apiV1UserBillingInfoShowPath: "/api/v1/user/billing_information/show",
        apiV1UserBillingInfoObiPaymentProviderPath: "/api/v1/user/billing_information/payment_provider",
        apiV1UserBillingInfoUpdatePath: "/api/v1/user/billing_information/update",
        basePath: basePath,
        commitmentsPath: commitmentsPath,
        commitmentsRelativePath: commitmentsRelativePath,
        contentsPath: "/news/slug",
        editContentsPath: editContentsPath,
        estimateTaxPath: "/api/v1/user/billing_information/estimate_tax",
        forecasterProfilePath: forecasterPagePath,
        forumsPath: "https://virginia.forums.rivals.com/",
        forumsStatisticsPath: "",
        galleriesPath: "/galleries",
        homepagePath: "/content/sport",
        newUserRegistrationPath: "/sign_up",
        newSiteSubscriptionPath: "/subscriptions/new",
        prospectApiPath: "/api/content/prospects",
        prospectCardPath: "/content/prospect_cards/id",
        prospectsPath: "/content/prospects/id",
        publishingDashboardUrl: publishingDashboardUrl,
        registerPath:  "/sign_up",
        rivals250Path: "/prospect_rankings?sport=rivals250",
        signInPath:  "/users/sign_in",
        signOutPath:  "/users/sign_out",
        siteUrl: siteUrl,
        subscribePath: "/users/subscriptions",
        trendingThreads: trendingThreads,
        userProfileEditPath: "/users/profile",
        userProfilePath: "/users/profile"
      };
    });
  }).call(this);
</script>
</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://virginia.rivals.com/news/weekend-wrap-loss-to-ncsu-an-accurate-frame-for-where-uva-is' property='og:url'>
<meta content='https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_thumbnail/nhy1lcjr8abhzclpzxq6' property='og:image'>
<meta content="The Weekend Wrap looks at the loss to NC State and what it does (and doesn't) mean as the Hoos enter their bye week." property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-10-01 06:04:01 -0500' property='article:published_time'>
<meta content='2018-10-01 06:04:02 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "virginia.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='virginia contents-show' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .virginia #programming > h1 {
      background-color: #ff6600 !important; } }
  .virginia > header .notification-link .count-container {
    background-color: #ff6600 !important; }
  .virginia > header .wrapper-container {
    background-color: #ff6600 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .virginia > header .wrapper-container {
        border-bottom: 5px solid #000036 !important; } }
  .virginia > header .invalid-email-banner {
    background-color: #ff6600;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .virginia > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .virginia > header .invalid-email-banner a:hover {
      color: #000036; }
  @media screen and (max-width: 767px) {
    .virginia > header .mobile-header {
      background-color: #000036 !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .virginia > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .virginia > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .virginia > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .virginia > header .nav-row > ul,
    .virginia > header .third-nav {
      background-color: white !important; }
    .virginia > header .dropdown-toggle > i.fa {
      color: #ff6600 !important; } }
  .virginia > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #ff6600; }
  
  .site-primary-font-color {
    color: #ff6600; }
  
  .site-primary-background-color {
    background-color: #ff6600; }
  
  .site-secondary-font-color {
    color: #000036; }
  
  .site-secondary-background-color {
    background-color: #000036; }
  
  :root {
    --outbrain-primary-color: #ff6600;
    --outbrain-secondary-color: #000036; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="https://rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Virginia" class="school-header" href="https://virginia.rivals.com/"><img src="https://res-4.cloudinary.com/rivals/image/upload/t4kjhpu9dbwgzaeffshg" alt="T4kjhpu9dbwgzaeffshg" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://virginia.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;virginia&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="https://virginia.rivals.com/">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;virginia&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert class='alert-nav'></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733168,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Weekend Wrap: Loss to NCSU an accurate frame for where UVa is"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='Cavs_Corner' name='twitter:site'>
<meta content='Weekend Wrap: Loss to NCSU an accurate frame for where UVa is' name='twitter:title'>
<meta content="The Weekend Wrap looks at the loss to NC State and what it does (and doesn't) mean as the Hoos enter their bye week." name='twitter:description'>
<meta content='https://res-5.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/nhy1lcjr8abhzclpzxq6' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init(nil, {"id":158,"legacy_id":927,"name":"CavsCorner.com","friendly_name":"Virginia","annual_discount":null,"subdomain":"virginia","primary_color":"ff6600","secondary_color":"000036","font_color":"ffffff","short_name":"virginia","maple_ncaaf_team_id":8,"maple_ncaaf_endpoint":"ncaaf/teams/vvb","maple_ncaab_team_id":618,"maple_ncaab_endpoint":"ncaab/teams/vaf","maple_college_id":8,"google_analytics_id":"UA-83297409-1"}, true, 187, nil, {"id":126,"primary_color":"ff6600","secondary_color":"000036","font_color":"ffffff","commitment_module_football":true,"rivals_module_football":false,"header_name":"","header_logo_cloudinary":"t4kjhpu9dbwgzaeffshg","mobile_header_logo_cloudinary":null,"google_analytics_id":"UA-83297409-1","logo_background_shading":"white","football_content":true,"basketball_content":true,"baseball_content":false,"other_content":false,"site_id":158,"created_at":"2016-11-23T13:38:44.304-06:00","updated_at":"2018-06-26T12:46:59.492-05:00","max_trending_articles":6,"enrichments":[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3},{"active":false,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardScores","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"ScoreboardPhotos","football":null,"list_id":null,"list_title":null,"position":null},{"active":false,"type":"TeamRankings","football":true,"list_id":null,"list_title":null,"position":null}],"footer_text":null,"sections":[],"supplied_domain":null,"message_board_link_url":"https://virginia.forums.rivals.com","scoreboard_scores_id":null,"scoreboard_photos_id":null,"aol_player_id":null,"aol_company_id":null,"ad_frequency":5,"display_twitter_follow":true,"display_fb_follow":false,"follow_twitter_handle":"Cavs_Corner","follow_fb_handle":null,"forum_id":null,"premium_forum_id":null,"facebook_page_id":null,"max_ticker_articles":8,"schedule_header_on":true},&#x000A;"58e686759efa8936610b8215", "58e68374c7480e728bcc385f", "rivals", 15000)'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>

<div class='article-container' ng-class='{"no-ad-padding": "#{@display_ldrb_top}"}'>
<div class='upsell-forecast-banner' ng-cloak='true'>
<rv-user-forecast-banner class='forecast-banner' upsell='true'></rv-user-forecast-banner>
</div>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #ff6600'>
Ticker
</div>
<rv-news-ticker contents='newsList' is_preview='false' is_publisher='isPublisher' profile_page='false' referral_code='referralCode'></rv-news-ticker>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://virginia.rivals.com/news/weekend-wrap-loss-to-ncsu-an-accurate-frame-for-where-uva-is' background-color='#ff6600' base-api-url='https://virginia.forums.rivals.com/' homepage='false' message-board-url='https://virginia.forums.rivals.com' pub-ad='null' size='size' space-id='2022733168' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='article-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://virginia.rivals.com/news/weekend-wrap-loss-to-ncsu-an-accurate-frame-for-where-uva-is/printable' site-name='CavsCorner.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-10-01 06:04:01 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1965704/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Weekend Wrap: Loss to NCSU an accurate frame for where UVa is</h2>
<div class='header-image'><figure class='article-image'>
<div class='blurred-image'>
<div class='background' style='background-image: url(https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/eua3vwmtp0mnyoujboxm)'></div>
<img src="https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/eua3vwmtp0mnyoujboxm" alt="Eua3vwmtp0mnyoujboxm" />
</div>
<figcaption class='image-caption'>NC State stymied Bryce Perkins on the ground while doing a much better job running the ball.</figcaption>
<div class='image-credit'>Associated Press</div>
</figure>
</div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<img class='circle-img' src='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/gmixv3ytqnsvlutn5gk2'>
<span>
<span class='title-sm'>
Brad Franklin
&bull;
</span>
<span class='type-sm'>CavsCorner.com</span>
<div class='type-sm'>
<a href='//twitter.com/Cavs_Corner' target='_blank'>@Cavs_Corner</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Publisher</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/Cavs_Corner'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>
Brad Franklin has served as the publisher of CavsCorner since February 2011. Email him anytime at brad.franklin@me.com. 
</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p>As Carter-Finley Stadium finally emptied out of the last few stragglers on Saturday afternoon, with event staff and site workers the lone souls left milling about, it occurred to me that pretty much everything we'd seen between the Cavaliers and Wolfpack seemed somewhat expected.</p><p>Maybe not the final margin, especially given where Las Vegas had pegged it going in. And perhaps not the specifics, with NC State running wild at times over a Virginia defense that had been pretty solid against the rush this season.</p><p>Ultimately, STL's Matt Trogdon may have best encapsulated what I was thinking as I rode the elevator back up to the press box.</p>
</div>
<div class='st__content-block st__content-block--tweet'>
<div class='center_tweet'><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Macro hot take. Virginia is good enough now to beat bad teams. It’s not good enough yet to beat good teams.</p>&mdash; Matt Trogdon (@Matt_Trogdon) <a href="https://twitter.com/Matt_Trogdon/status/1046114051028389888?ref_src=twsrc%5Etfw">September 29, 2018</a></blockquote>
<script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p>It's unlikely<b> Bronco Mendenhall </b>would agree with the phrasing but he shared some similar thoughts following the 35-21 loss.</p><p>"We played well enough to make it interesting but not well enough to win the game," he explained. "Our inability to run the ball consistently and their surprising ability to run the ball, those two things kind of were the backstory of I think what led to the outcome as it was. I was encouraged when it was 27-14, we had the ball down there and went for it on 4th. I thought we had a great chance now to finish this game out and possibly pull off a comeback. But again, just not consistent enough to make that play."</p><p>In its first ACC loss—which might not have been quite as close as the score would imply given UVa's late-game offense—the Wahoos at times looked up to the challenge. But the Wolfpack offense was too good, it's run defense too stout. Particularly important was what the two teams did (NC State went 8-for-13) and didn't do (UVa went 4-for-13) on 3rd down.</p><p>Mendenhall had praise for <b>Bryce Perkins</b>' "effort and competitive spirit and ability and effectiveness," for the ability of<b> Tavares Kelly</b> to emerge, and for the <b>AJ Mejia</b>'s well-executed on-side kick late. </p><p>"There just simply wasn't enough of those plays to win the game," he added.</p><p>Down two starters on D and facing arguably the league's best signal caller, this game was going to be especially difficult for UVa to win on the road. The Hoos may have ended up passing for a yard more than NC State but the Pack got anything they wanted and Finley, who may not have been at his sharpest but was still 22 for 32 for 257 yards and three TDs, showed out.</p><p>Against another big, strong offensive line and trying to account for the challenges of the passing game by getting more DBs on the field, UVa gambled by not playing a true NT and it showed in the run defense all while not doing much to knock Finley's timing off its typical tracks.</p><p>"We kind of pride ourselves," Mendenhall said, "on being able to hit the quarterback and we didn't. And so their protection and the ability to throw and catch the football or throw with incompletes and have us pass interfere, not defend cleanly. It's basically the same result, right? </p><p>"So they threw and caught and protected on 3rd down," he added, "better than we rushed and covered and executed." </p><p>Sometimes, the game is that simple.</p><p>Of course, that didn't mean there weren't some odd plays. Had a video review gone UVa's way on State's 4th and inches play in the second quarter, with the game 10-7 for the Pack, it's impossible to know how the Cavaliers would've responded. Instead of getting the ball back on Finley's fumble, the officials ruled he made the line to gain and NCSU scored shortly thereafter.</p><p>"I was told by the official that it wasn't going to be a 1st down," Mendenhall said, "that we had stopped him. So once I was told that then we sent our offense out and then they changed their mind."</p><p>Still, the nuts and bolts of this game have more to do with where Dave Doeren and the Wolfpack are in Year 6 versus where Mendenhall and Co. are in Year 3. </p><p>"I would say that we we were realistic," he explained, "but certainly disappointed of our result and we're just getting a clearer idea where our matchups, where our execution, where those areas really are and each game we play gives us more feedback."</p><p>The fact that State had so much success on the ground, especially considering its lack of rushing bonafides coming in, was a big surprise. To UVa, it seemed familiar particularly without <b>Jordan Mack</b> in the middle.</p><p>"I can see the inconsistencies right in front of my eyes," Mendenhall said. "And so I'll give [RB Ricky Person] credit for running the ball well but our execution, it doesn't look like a flat wall meaning every gap handled. We're just inconsistent and we saw it again once this year early, in Indiana, kind of got [it] addressed, and then I saw it again today and surprisingly so. Thought it was fixed but it wasn't."</p><p>The Wahoos now get a week off to not only get healthy but to also reassess and improve. Miami will be waiting on the other side of the bye week and then an intriguing slate of games commences the rest of the way.</p><p>For now, the program remains one in building mode and still has to find a way to be more consistent to win games against teams that are simply deeper in that phase.</p><p>"It was just enough to kind of make it intriguing there for a minute," Mendenhall said, "but not good enough to take it over." </p>
</div>
<div class='st__content-block st__content-block--text article-text'>
<p><b><i><br></i></b></p><p><b><i>JOIN CAVSCORNER TODAY!</i></b></p><p>If you are not already a member of CavsCorner, come join us and see what all of the buzz is about.</p><p>Click <b><i><a href="https://n.rivals.com/users/sign_up">HERE</a></i> </b>to subscribe<b> </b>and get all of the latest news and join hundreds of other UVa fans in talking about Cavalier football, basketball, and recruiting. You won't be disappointed!</p><p><br></p>
</div>
<figure class='article-image'>
<div class='blurred-image'>
<a href='https://virginia.forums.rivals.com/forums/hoos-next.6/' target='_blank'>
<div class='background' style='background-image: url(https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/sexnc6jhpp0kflqsqyok)'></div>
<img src="https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/sexnc6jhpp0kflqsqyok" alt="Sexnc6jhpp0kflqsqyok" />
</a>
</div>
<figcaption class='image-caption'></figcaption>
<div class='image-credit'></div>
</figure>
</div>
<div class='text-center'>
<rv-share-links print-url='https://virginia.rivals.com/news/weekend-wrap-loss-to-ncsu-an-accurate-frame-for-where-uva-is/printable' site-name='CavsCorner.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' is_schedule_football='true' ncaab-schedule-year='2018' ncaaf-schedule-year='2018' site='{"id":158,"legacy_id":927,"name":"CavsCorner.com","friendly_name":"Virginia","annual_discount":null,"subdomain":"virginia","primary_color":"ff6600","secondary_color":"000036","font_color":"ffffff","short_name":"virginia","maple_ncaaf_team_id":8,"maple_ncaaf_endpoint":"ncaaf/teams/vvb","maple_ncaab_team_id":618,"maple_ncaab_endpoint":"ncaab/teams/vaf","maple_college_id":8,"google_analytics_id":"UA-83297409-1"}' twitter-feed='{"id":157,"site_id":158,"handle":"Cavs_Corner","list_name":"CavsCorner-Twitter-Feed","created_at":"2016-02-01T12:25:34.750-06:00","updated_at":"2018-06-26T12:44:32.848-05:00","hashtags":[],"usernames":[],"max_number":0}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://virginia.rivals.com/news/weekend-wrap-loss-to-ncsu-an-accurate-frame-for-where-uva-is/printable' site-name='CavsCorner.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733168', 'https://virginia.rivals.com/news/weekend-wrap-loss-to-ncsu-an-accurate-frame-for-where-uva-is');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Weekend Wrap: Loss to NCSU an accurate frame for where UVa is";
  _sf_async_config.sections = 'content,content-football,content-football-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://virginia.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Oath Inc</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733168",
    c7: "https://virginia.rivals.com/news/weekend-wrap-loss-to-ncsu-an-accurate-frame-for-where-uva-is"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fvirginia.rivals.com%2Fnews%2Fweekend-wrap-loss-to-ncsu-an-accurate-frame-for-where-uva-is&c5=2022733168&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
